Welcome! Anonymous

Lost fonts on F14

A place to ask questions, or discuss anything related to infinality.net stuff.

Lost fonts on F14

Postby jukk » Wed Nov 17, 2010 1:10 pm

Hi

Thanks for the effort. I have enjoyed the beautiful font rendering.

However, something seems broken on Fedora 14 currently. I think it was because freetype was updated today from the fedora repo. I lost all fonts and text in gnome. After uninstalling the infinality rpms I got my fonts back. I tried reinstalling the infinality rpms but it didn't help.
jukk
 
Posts: 5
Joined: Wed Nov 17, 2010 12:54 pm

Re: Lost fonts on F14

Postby infinality » Wed Nov 17, 2010 3:29 pm

Are you using the settings defined on this page? (.Xresources, local.conf, etc?)

http://www.infinality.net/blog/?p=67
- Linux font rendering has gone from the most reviled to the most renowned.
User avatar
infinality
Site Admin
 
Posts: 733
Joined: Wed Oct 20, 2010 7:57 am
Location: Wisconsin, USA

Re: Lost fonts on F14

Postby jukk » Wed Nov 17, 2010 3:47 pm

Yes, I did everything by the book a couple of weeks ago when still on Fedora 13 and it looked very good. A few days ago I updated to Fedora 14 and it still was fine. Today I noticed that all text was gone in gnome when I logged in. The freetype package was updated a couple of hours earlier, that's why I suspected it.
jukk
 
Posts: 5
Joined: Wed Nov 17, 2010 12:54 pm

Re: Lost fonts on F14

Postby jib » Wed Nov 17, 2010 4:09 pm

Same problem for some users on Arch.
See user comments at http://aur.archlinux.org/packages.php?ID=38888

Fonts can't be seen unless the line
export INFINALITY_FT_FILTER_PARAMS
is commented out in /etc/profile.d/infinality.sh
jib
 
Posts: 4
Joined: Wed Nov 17, 2010 4:04 pm

Re: Lost fonts on F14

Postby infinality » Wed Nov 17, 2010 4:51 pm

I can only duplicate the issue if I set:
INFINALITY_FT_FILTER_PARAMS=

If the environment variable isn't present, I see fonts. If the variable is set to one of the options I suggest in the infinality-settings file, I see fonts.

I will add better error checking to ignore incorrectly specified options. Hopefully that will alleviate some of the problems.
- Linux font rendering has gone from the most reviled to the most renowned.
User avatar
infinality
Site Admin
 
Posts: 733
Joined: Wed Oct 20, 2010 7:57 am
Location: Wisconsin, USA

Re: Lost fonts on F14

Postby jib » Wed Nov 17, 2010 5:20 pm

Thanks for your answer.
The option was correctly set since i hadn't made any changes to infinality-settings.sh

Line 49 was :
Code: Select all
export INFINALITY_FT_FILTER_PARAMS="0.11 0.22 0.38 0.22 0.11"

=> fonts couldn't be seen.
I tried other values with no effect.

Now the line is
Code: Select all
#export INFINALITY_FT_FILTER_PARAMS="0.11 0.22 0.38 0.22 0.11"

fonts can be seen.
jib
 
Posts: 4
Joined: Wed Nov 17, 2010 4:04 pm

Re: Lost fonts on F14

Postby infinality » Wed Nov 17, 2010 5:35 pm

Interesting. Do any of the other options have any effect on the fonts? For instance, if you adjust the stem alignment or autohint stem snapping to another valid setting, do you see an effect in the fonts? I'm just wondering if maybe the environment variables aren't working as intended in general.
- Linux font rendering has gone from the most reviled to the most renowned.
User avatar
infinality
Site Admin
 
Posts: 733
Joined: Wed Oct 20, 2010 7:57 am
Location: Wisconsin, USA

Re: Lost fonts on F14

Postby infinality » Wed Nov 17, 2010 7:27 pm

I've posted a patch here to do more checking on the input for INFINALITY_FT_FILTER_PARAMS. I'd like to see if it fixes the problems on those who are having issues. If it does, I will produce some updated Fedora packages.

EDIT: This patch should be applied on top of the 2010-11-14 patch.
EDIT2: Fedora packages have been updated too.

http://www.infinality.net/files/freetyp ... 17-1.patch
- Linux font rendering has gone from the most reviled to the most renowned.
User avatar
infinality
Site Admin
 
Posts: 733
Joined: Wed Oct 20, 2010 7:57 am
Location: Wisconsin, USA

Re: Lost fonts on F14

Postby bhna » Thu Nov 18, 2010 1:39 am

Thank you for the last update. My fonts are back and beautiful.
bhna
 
Posts: 4
Joined: Wed Nov 17, 2010 7:04 am

Re: Lost fonts on F14

Postby jukk » Thu Nov 18, 2010 2:55 am

Thanks for the update. I'll check it out tonight when I have more visible access than an SSH prompt.
jukk
 
Posts: 5
Joined: Wed Nov 17, 2010 12:54 pm

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests